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1 Introduction

Bria Professional is CounterPath’s softphone designed specifically for business and enterprise users. It includes 
the features that are standard to Bria—the ability to make VoIP phone calls, to send and receive instant 
messages (IM), to share presence (availability) information, and to exchange files. Bria Professional adds to 
those features the ability to auto-answer incoming calls and support for LDAP.

A system administrator in an enterprise can provision the application remotely (with or without DHCP), and 
automatically install the .msi package across an enterprise.

instant messaging (Standard Telephone Features
The CounterPath Bria Professional has all standard enterprise telephone features, including:

• Call display and Message Waiting Indicator (MWI).
• Speakerphone and Mute.
• Redial, Hold, Do Not Disturb.
• Call history – list of received, missed, and dialed calls.
• Call transfer.
• Call record.
• Auto answer.
• Six-party audio conferencing.
• Three-party video conferencing.

Enhanced Features and Functions
The CounterPath Bria Professional also supports the following features and functions:

• IM and presence using the SIMPLE protocol or the XMPP protocol.
• IM conferencing (Group Chat) via an XMPP account.
• Managed contact list – importing and exporting contacts between Bria Professional and other applications.
• File transfer via an XMPP account.
• File transfer via content indirection (by sending the files to a file transfer server for “pickup” by the other 

party).
• Support for LDAP.
• Automatic detection and configuration of audio and video devices.
• Acoustic echo cancellation, automatic gain control, voice activity detection.
• Support for the following audio codecs:

AMR Wideband (G.722.2), Broadvoice-32, Broadvoice-32 FEC, DVI4, DVI4 Wideband, G.711aLaw, 
G.711uLaw, G.723, G.726, G.729, GSM, iLBC, L16 PCM Wideband, Speex, Speex FEC, Speex Wideband, 
Speex Wideband FEC.
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• Support for the following video codecs:
H.263, H.263+ 1998, H.264.

• Automatic selection of the best codec based on the other party’s capability, the available bandwidth, and 
network conditions. Bria Professional switches the codec within a call in response to changing network 
conditions.

• SIP compliance to 3261 SIP standard.
• XMPP compliance as follows:

• RFC 3920
• RFC 3921
Supported extensions:

• XEP-0004
• XEP-0016
• XEP-0022
• XEP-0077
• XEP-0085
• XEP-0092
• XEP-0115

• STUN and ICE NAT traversal. XTunnels for firewall traversal.
• Support for DTMF (RFC 2833, inband DTMF or SIP INFO messages). 
• Support for languages.
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2 Installation and Setup

2.1 Getting Ready

Multimedia Device Requirements
Bria Professional requires both speakers and a microphone to make calls. Any of the following configurations 
are acceptable:

• External speakers and microphone
• Built-in speakers and microphone
• Dual-jack multimedia headset
• Bluetooth® multimedia headset
• USB multimedia headset
• USB phone. 

Optimized Devices
Bria Professional is optimized to work with the following:

• Actiontec Internet Phone Wizard
• GN Netcom GN 8120 USB and GN Netcom 8110 USBXP
• Plantronics CS50-USB Wireless Office Headset System
• Polycom® Communicator C100S Wideband USB Speakerphone
• TigerJet RJ11 to USB Phone Adaptor (incorporating the Tiger560C)
• TigerJet USB Phone Set (incorporating the Tiger560C)
• Yealink USB-P1K USB hand phone

Video Cameras
Calls made with Bria Professional will work without a video camera, but one is necessary to allow other parties 
to see your image. Bria Professional will work with most USB video cameras.
3



CounterPath Corporation
2.2 Starting Bria Professional
If Bria Professional is not already running, start it as you would any other program: Use the Windows 
Start menu or double-click the desktop icon. Either the Login window or the softphone itself appears. If 
the login window appears, enter the credentials provided by your system administrator.
 

2.3 Configuring Bria Professional
Read this section if your system administrator advises you that you must either configure Bria Professional or 
complete the configuration.

(If your administrator advises you that configuration is already done, go to “Setting up a Contact List” on 
page 5.)

1. Choose File > Account Settings.

2. Create or modify accounts as instructed by your administrator. See the following pages for details. When 
done, return to the Account Settings window and click Apply to register the accounts. Click Close when the 
Status column is “Ready”. 
4
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2.4 Setting up a Contact List
Typically, you will want to create contacts in order to easily make phone calls, send IMs and transfer files. You 
can set up contacts in several ways:
• During a call that you place or receive, you can add the other party to your contact list. See “Handling an 

Established Call” on page 17.
• You can add addresses to the Contact list one by one. See “Adding a Contact” on page 36.
• You can import a contact list from a file or from another application. See “Importing Contacts” on page 38.
• You can create a contact from an entry in the LDAP directory; see “LDAP Directory Tab” on page 49.
For general information on contacts, see “Contacts Tab” on page 35.
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3 Using Bria Professional

3.1 Starting Bria Professional
If Bria Professional is not already running, start it as you would any other program: Use the Windows 
Start menu or double-click the desktop icon. Bria Professional appears. 

Receiving a Presence Request
If availability is enabled, then at any time you may get a Presence Request dialog box. For information on this 
request, see “Availability” on page 42.

  

3.2 Shutting Down
To shut down Bria Professional, click File > Exit, or press Ctrl+Q. Note that clicking the Close button (X) on 
the softphone minimizes Bria Professional to the system tray; it does not exit.
7
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3.3 The Onscreen Softphone 

The Bria Professional Menu

File
• My Profile. See page 51.
• Preferences. These settings control the way that you work with Bria Professional and apply to all accounts. 

See page 52.
• Account Settings. You will work with these settings only if advised to do so by your system administrator. 

See “Configuring Bria Professional” on page 4. 
• Sign Out. To log off and minimize Bria Professional to the system tray. If you click the Bria Professional 

icon in the status bar, the Login screen appears.This menu item does not appear if you have configured Bria 
Professional for no login (page 61).

• Exit. To shut down Bria Professional. You can also exit by pressing Ctrl+Q.

View
• Change the GUI. See “Showing and Hiding Parts of the Softphone” on page 10.

Call panel. 
See page 12.

Bria Professional 
menu. See below.

Address Book panel. 
See page 35.
8
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Contacts
Lets you work with contacts. Everything in this menu except for import and export can also be performed 
directly in the Address Book panel. 

For information on these actions, including import and export, see page 35.

For information on managing blocked contacts, see “Privacy” on page 47.

Actions
Lists the actions that you can perform, depending on the current “state” of Bria Professional. For example, if a 
contact is selected, it lists all the actions that can be performed on that contact.

If your enterprise has configured Bria Professional to display a Workgroup, you can view the Workgroup from 
the Actions menu.

Help
Provides access to various service-related features. 
9
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Showing and Hiding Parts of the Softphone

You can still receive calls when Bria Professional is hidden or minimized. 

If you exit when Bria Professional is minimized or in Deskbar mode; Bria Professional will start next time as 
minimized or in Deskbar mode.

The Deskbar
To display the softphone as a deskbar, click the Deskbar button.

Show/hide Video panel

Show/hide Dial pad

Display as Deskbar. See page 10

Close Call panel (only Call entry field will 
remain). Click again to open.

Show/hide Address Book

Move Address Book to a separate window

Drag to resize

Restore to large view

Close to System Tray

Deskbar
10
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The Deskbar provides a compact GUI for performing many Bria Professional actions. It is assumed that you 
will work in this mode after you are quite familiar with Bria Professional and its features.

Deskbar button

Your availability Switches between Call 
button and End button

Menu changes depending on whether 
there is an entry in the entry fieldEntry field

Restore to main window

Missed calls
11
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3.4 Placing a Call
You can contact someone using:

• A softphone address (for example, kpereira@domainA.com)
• A traditional phone number.

You can place a call when another call is already in progress. There is no limit to the number of calls you can 
make, although eventually the quality of audio and video will degrade because of limitations on the computer. 
We recommend no more than six concurrent calls.   

1. If you have a camera on your computer, decide how you want to handle video for this call:

• The Video panel must be open if you want to send your video immediately. When the Video panel is 
opened, the Video button appears on the Call panel.
(You always have the option of starting the call without video and then adding it later).

• The Video panel can be opened or closed if you do not want to send video. 

2. Place the call. See the table below. 

The new call is added to the Current Calls bar. You will hear a ringing tone while Bria Professional attempts 
to make a connection.

3. Once the new call is established, switch between different calls by clicking the tab in the Current Calls bar.

Redial

Call entry field

Click a button to place the call. If 
the Video panel was open, a Video 
Call button would also appear 
here.

Current Calls bar

Call toolbar

Other calls are on hold

Filter

Open/close Video panel
12
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How From the... Description

Keying Dialpad or computer 
keyboard 1. If another call is currently in progress, click  on the Call toolbar. 

A new Call Entry area appears. The current call is put on hold.
2.  Enter the softphone address or number in the Call entry field using 

the dialpad or the computer keyboard.

For the name, you can enter the entire softphone address 
(kpereira@domain.com) or just the name (kpereira).
As you type, a suggestion for completing the entry may appear. 
Choose the suggestion or keep typing.

3. To make an audio call, click the green Call button or press Enter. 
Even if the Video panel is open, an audio call will be placed.

4. Or to make a video call, open the Video panel and press Video Call.

Drag-and-drop contact or 
previous call

Contacts or History tab in the 
Address Book panel

Drag an entry from the Contacts or History tab. The call is placed 

immediately. (If the tab contains lots of contacts, first use the  field 
to filter the list.)
• If the video panel is closed, an audio call is placed.
• If the video panel is open, a video call is placed and your video will 

be sent as soon as the other party answers. 

Right-click a contact or 
previous call

Contacts or History tab in the 
Address Book panel

Right-click an entry from the Contacts or History tab and choose Call or 
Video Call. The call is placed immediately. 

(If the tab contains lots of entries, first use the  field to filter the 
list.)

Double-click a contact Contacts in the Address Book 
panel

Contacts have a “double-click” action that either makes a phone call or 
starts an IM. Each contact can be configured separately for this action. 
See Table 1 on page 36.

Double-click a previous 
call

History tab in the Address 
Book panel

Double-click an entry. The call is placed.

Redial Redial button Click Options and choose Redial. Or click the Redial button. 
The call is placed immediately (without video, even if the Video panel 
is open).

Right-click an LDAP 
entry

Directory tab in the Address 
Book panel

If you have set up an LDAP directory (page 59), right-click an entry 
from the Directory tab and choose Call or Video Call. The call is placed 
immediately.

(If the tab contains lots of entries, first use the  field to filter the 
list.)

From Outlook If you have set up contacts in Microsoft® Outlook®, you can place a 
call to a PSTN number (but not a softphone address). 
1. Double-click the contact in the contact list in Outlook. The Contact 

dialog box appears. 

2. Click the  in the top left corner and select the phone number to 
dial. As soon as you release, Bria Professional will be brought to the 
front (or will be started) and the call will be placed.

If you cannot make a call from Outlook, speak to your system 
administrator; the account dial plans may need to be revised.
For information on how Bria Professional and Outlook contacts work 
together, see “Exporting Contacts” on page 39.

Dialing Dialpad 1. If the dialpad is not visible, click the Show/Hide Dialpad button.
2. Click the numbers on the dialpad to enter the phone number.
3. Click the green Call button or press Enter.
13
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Placing another Call
To place a new call (without hanging up on the current call), click the Start another Call button. In the Current 
Calls bar, a tab appears for each separate call.

Hiding your Identity
You can hide your identity on a call, so that the other person will not see your ID on their phone.

Click Options > Hide my Number for this Call.  appears on the Call control bar for this call. Place the call in 
the usual way.

Your identity is hidden only for this call. 

Which Account Is Used?
When placing an outgoing call, you can explicitly specify the account to use for that call. Click the Account 
Selection menu and select the desired account.

Once the call is placed, this menu always reverts back to “Auto”.

Start another Call 
button
14
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If You Do not Select an Account – Auto Account

If you have more than one account enabled and if you do not select the account, Bria Professional selects the 
account to use to place the call as follows:

• If a dial plan exists for any account, Bria Professional runs through the dial plans to determine if the dialed 
number matches any of these plans. If a match is found, the account that the dial plan belongs to is used. 
Your system administrator will have already set up suitable dial plans. 

• If there is no match on any dial plans or if no dial plans are defined, then the default account is used. The 
default account is the account listed first in the Account Settings window (page 62).

Encryption
The outgoing call may be encrypted, depending on your security settings. 

• If an encrypted call is established, the encryption icon ( ) appears on the call display. This icon indicates 
that the call is guaranteed to be secure between you and your proxy, and may or may not be secure beyond 
that first hop. 

• If an unencrypted call is established, no encryption icon appears.
• If the call cannot be established with the specified security, the call will fail.

Ending a Call
Click End on the Call panel. Details of the call remain on the call display. To clear the details of the call from 
the display, click Clear. 
15
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3.5 Handling an Incoming Call
Bria Professional must be running to answer incoming calls. (If Bria Professional is not running, incoming calls 
may be directed to voicemail; check with your system administrator.)

Bria Professional rings and information about the incoming call 
appears in the Call entry field. In addition, the Call Alert box appears, 
even if Bria Professional is minimized. For information on call alerts, 
see “Preferences – Alerts & Sounds” on page 53.       

The softphone address of the person calling you is displayed. The 
display name may also appear. 

Ending a Call
Click End on the Call panel. Details of the call remain on the call display. To clear the call display, click Clear.

Auto Answer
To turn auto answer off and on, in the Call panel click Options > Auto Answer. The AA icon appears in the call 
display.

Auto answer is initially configured to auto-answer after one ring, and to send only your audio when the call is 
established. You can change this configuration; see “Preferences – Advanced” on page 61.

Auto answer is automatically turned off when you shut down or log off.

Action From the... Description

Answer Call panel or Call Alert box Click Answer.
If you are on another call, that first call is automatically put on hold. You are 
now talking to the new caller.
Or press Enter (on the keyboard), if Bria Professional is the active application.

Decline Call panel or Call Alert box Click Decline. There will be a busy signal. In some networks, the call will be 
directed to voicemail (if you have this service).

Permanently 
block the caller

Options menu Click the Options button and choose Block this person.

Answer with IM Options menu Click Options and choose Answer with Instant Message. The phone call is 
declined, and instead an Instant Message window appears. Type the message 
and click Send. (Or close the window if you change your mind.)
16
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3.6 Handling an Established Call
While the call is in progress you can:

• Control the audio: use the speakerphone, mute the call, control volume.
• Record the call.
• Put the call on hold.
• Add the caller as a contact.
• Transfer the call. See the next page.
• Add video. Pause and resume video when video is already present. See “Video” on page 20

Show/hide video panel. See page 20

Speakerphone (this button only 
appears if your computer has a 
speakerphone)

Hold

Mute

Volume control

You can do any of these 
even with the call in 
progress. Many of these 
actions are also buttons on 
the Call toolbar.

Quick transfer. See page 18

Place another call (this one will automatically be 
put on hold). See page 14

Conference call. See page 22

Record on/off

Add the current 
caller as a contact. 
See “Adding a 
Contact using an 
Existing Address” on 
page 37.
17
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3.7 Transfering a Call

Quick Transfer
You can set up a list of phone numbers that calls can be transferred to. Then during a call, you can transfer to 
any of these numbers by selecting from a list.

To set up the numbers:

1. Click File > Preferences from the menu. Display the Transfer panel.

2. Enter as many numbers as you want. To enter a new number, click in an empty line. To remove an entry, 
click in the line and delete the number.

Set one of the numbers as the default and click OK.

To transfer a call, click the arrow on the Transfer button and click the number to transfer to. As soon as the 
transfer is made (the other phone starts ringing), the call is disconnected at your end. 

Basic (Unattended) Transfer – Transfer this Call
You can transfer a call to any number, then hang up as soon as you have entered the number. 

1. Click Options > Transfer this Call. The call display prompts for the number to transfer to.

2. Call the target (the person you are transfering the call to) by keying the number.

3. Click Transfer; the message Transfer Successful appears.

Or click Cancel to continue the current call.

Quick Transfer
18



Bria Professional 2.4 for Windows User Guide
Attended Transfer – Call then Transfer
You can first speak to the target (the person you are transfering the call to), then click Transfer to complete the 
transfer.

1. Click Options > Call then Transfer. The first call is put on hold and a New call tab appears

2. Call the target in any of the normal ways.

3. When you are ready, click Transfer; the message Transfer Successful appears.

If the target does not want to take the call, simply end the call with that person. The first call is taken off hold.
19
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3.8 Video

Adding Video

Either you or the other party can add video at any time.

To add video, open the Video panel and click Start My Video. When you add video, the other party may (or may 
not) start sending their video to you.

You can add video, even if you do not have a camera, in order to start receiving the other party’s video.

Other Party Adds Video

If the other party starts their video, the Video panel automatically opens and the video is played. You can start 
sending your own video, if desired (and assuming you have a camera) by clicking Start My Video.

Pausing and Resuming Video

If the Video panel is open and video exists in a call, the Start My Video and Stop My Video buttons appear, to 
let you pause and resume video.

If you close the Video panel, your video will stop being sent; you can reopen the panel and click Start My Video 
again.

Show/hide video 
panel

Control video from the Call panel 
or the Video panel

This button only appears 
when video panel is open
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